Looking for
or
?
We've rebranded!
API Docs

Swift compatibility: Which Swift versions are supported?

Starting with the SDK version 10.19.0 we enabled library evolution and module stability which allows to use the SDK from now on with any Xcode 11+ (beta) version that supports at least Swift 5.1.

Older releases of the SDK were bound to a specific build of Xcode. If you were required to use an older version of Xcode, you unfortunately had to use an older version of PhotoEditor SDK as well.

We updated the SDK very quickly after a new release of Xcode, so that a matching build was usually available within a couple of days at most. In most cases we also offered prereleases of the SDK, which could be used with prereleases of Xcode. Those prereleases were then available on GitHub and named after the Xcode prerelease they were built with. Unfortunately we couldn’t distribute prereleases via CocoaPods.